Home > Fatal Error > Fatal Error Ppl_c.h

Fatal Error Ppl_c.h

configure:5357: $? = 1 configure: failed program was: | /* confdefs.h */ | #define PACKAGE_NAME "OpenSC" | #define PACKAGE_TARNAME "opensc" | #define PACKAGE_VERSION "0.14.0" | #define PACKAGE_STRING "OpenSC 0.14.0" | #define Few months ago when i was using mavericks it was working. is it --without-ppl ??I think you have misunderstood.  To skip PPL you do not need to doanything. Thanks Prathyusha Uploading my config.log file again. have a peek at these guys

ar checking for strip... and what is ur architecture ? configure:6506: $? = 1 configure: failed program was: | /* confdefs.h */ | #define PACKAGE_NAME "" | #define PACKAGE_TARNAME "" | #define PACKAGE_VERSION "" | #define PACKAGE_STRING "" | #define PACKAGE_BUGREPORT yes checking for dlfcn.h... https://gcc.gnu.org/ml/gcc-help/2011-03/msg00411.html

yes checking for _doprnt... yes checking for gcc option to produce PIC... -fno-common -DPIC checking if gcc PIC flag -fno-common -DPIC works... You should see "C preprocessor "/lib/cpp" fails sanity check" somewhere in config.log. none required checking whether pthreads work with -pthread...

yes checking for fcntl.h... Or maybe I just need to set all of those variables (PACKAGE_NAME, PACKAGE_TARNAME, etc.) somewhere...I didn't see anything regarding those in the documentation, though. But if you use my config-gcc.mk then you won't get that error, and it will skip PPL, and it will just work.? OpenCores, registered trademark.

So got past the error Cannot compute suffix of object files. This file contains any messages produced by compilers while running configure, to aid debugging if configure makes a mistake. Thanks Prathyusha I am trying to install GNU tool chain on Ubuntu Linux , but not having success. Any help is greatly appreciated.

RE: Problem installing newlib toolchain in Linux by olof on Aug 2, 2011 Quote olof Posts: 205 Joined: Feb 10, 2010 Last seen: Nov 11, 2016 Hi again, Seems like you Whatshould I do in order to tell gcc where is libmpc.so.2 ?regards,// Naderan *Mahmood;----- Original Message ----From: Jonathan Wakely <***@gmail.com>To: Mahmood Naderan <***@yahoo.com>Cc: gcc Sent: Thu, March 31, 2011 5:50:59 PMSubject: I have the following error when I try to run the bld-all.sh script. This is free software; see the source for copying conditions.

configure:4336: $? = 0 configure:4325: gcc -v >&5 Using built-in specs. yes checking for error_at_line... yes checking fcntl.h presence... I am using version 7.0, and I am on chapter 6.17.

Adding multilib support to Makefile in ../../../../unisrc/libgloss/libnosys with_multisubdir= config.status: creating config.h config.status: executing depfiles commands make (all-target-libgcc all-target-libstdc++-v3 all-target-newlib all-target-libgloss) failed. http://radionasim.com/fatal-error/fatal-error-605.php configure:6519: $? = 1 configure: failed program was: | /* confdefs.h */ | #define PACKAGE_NAME "" | #define PACKAGE_TARNAME "" | #define PACKAGE_VERSION "" | #define PACKAGE_STRING "" | #define PACKAGE_BUGREPORT weibullguy View Public Profile View LQ Blog View Review Entries View HCL Entries Visit weibullguy's homepage! yes checking for /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ld option to reload object files... -r checking for objdump...

no checking how to recognize dependent libraries... yes checking for unistd.h... that's not the error that cause configure to fail.Post by Mahmood Naderanconfigure:5795: gcc -c -g -O2    conftest.c >&5conftest.c:10: fatal error: ppl_c.h: No such file or directorycompilation terminated.configure:5795: $? = 1Where can check my blog yes checking getopt.h presence...

Secondly, regarding confdef.h, according to the conf.log, I just need to override the GCC internal prototype using "char" to avoid this error. yes checking for readline in -lreadline... ar checking for strip...

yes checking whether to build static libraries...

no checking for RSA_version in -lcrypto... here is version check list: bash, version 4.3.11(1)-release /bin/sh -> /bin/dash Binutils: (GNU Binutils for Ubuntu) 2.24 bison (GNU Bison) 3.0.2 /usr/bin/yacc -> /usr/bin/bison.yacc bzip2, Version 1.0.6, 6-Sept-2010. RE: Problem installing newlib toolchain in Linux by pekon on Jul 29, 2011 Quote pekon Posts: 28 Joined: Mar 6, 2009 Last seen: Apr 16, 2016 Hi, I faced similar problem.. So forget about PPL.The error that caused configure to fail is the "cannot compute suffixof object files"You didn't read http://gcc.gnu.org/wiki/FAQ#configure_suffix carefully- that FAQ answer tells you which config.log to look in,

Mahmood Naderan 2011-03-31 17:40:07 UTC PermalinkRaw Message     /usr/lib/mysql    /opt/meego/lib    /usr/lib/qt-3.3/lib    /usr/lib/xulrunner-1.9.2Mine is:***@pc:/etc$  cat ld.so.conf.d/*.conf/usr/lib/mesa# Multiarch support/lib/i686-linux-gnu/usr/lib/i686-linux-gnu/usr/lib/alsa-lib# libc default configuration/usr/local/lib The strange thing for me was that with Which version of cloog are you using? Jonathan Wakely 2011-03-31 18:08:08 UTC PermalinkRaw Message Post by Mahmood Naderan    /usr/lib/mysql    /opt/meego/lib    /usr/lib/qt-3.3/lib    /usr/lib/xulrunner-1.9.2/usr/lib/mesa# Multiarch support/lib/i686-linux-gnu/usr/lib/i686-linux-gnu/usr/lib/alsa-lib# libc default configuration/usr/local/libThe strange thing for me was that with news gcc -E checking whether ln -s works...

If you're not going to read the documentation properly, please just use that makefile and save a lot of wasted time. yes checking if libtool supports shared libraries... Or is this the entire config.log. configure:6494: $? = 1 configure: failed program was: | /* confdefs.h */ | #define PACKAGE_NAME "" | #define PACKAGE_TARNAME "" | #define PACKAGE_VERSION "" | #define PACKAGE_STRING "" | #define PACKAGE_BUGREPORT

yes checking whether to build shared libraries... I never had any problems, but it seems like other people have. I have no good ideas for this, but looking around the internet it seems that other people have had cloog-related problems too, so we can start by sorting some things out yes checking for strlcat...

COLLECT_GCC=g++ COLLECT_LTO_WRAPPER=/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/lto-wrapper Target: i686-linux-gnu Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.5.2-8ubuntu4' --with-bugurl=file:///usr/share/doc/gcc-4.5/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.5 --enable-shared --enable-multiarch --with-multiarch-defaults=i386-linux-gnu --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib/i386-linux-gnu --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.5 --libdir=/usr/lib/i386-linux-gnu --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-plugin --enable-gold It could be related. yes checking for OPENSSL... no checking for suffix of object files...

yes checking zlib.h presence... LFS is a project that provides you with the steps necessary to build your own custom Linux system. configure:5755: $? = 1| } configure:5764: result: no configure:5778: checking for version 0.11 (revision 0 or later) of PPL configure:5795: gcc -c -g -O2 conftest.c >&5 conftest.c:10:19: fatal error: ppl_c.h: No Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home Forums HCL Reviews Tutorials Articles Register Search Search Forums Advanced Search Search Tags Search LQ Wiki Search Tutorials/Articles Search

yes checking size of void *... 8 checking for socket in -lsocket... configure:12583: $? = 1 configure: failed program was: | /* confdefs.h */ | #define PACKAGE_NAME "OpenSC" | #define PACKAGE_TARNAME "opensc" | #define PACKAGE_VERSION "0.14.0" | #define PACKAGE_STRING "OpenSC 0.14.0" | #define configure: error: inconfigure: error: cannot compute suffix of object files: cannot compileSee `config.log' for more details.make[2]: *** [configure-stage1-target-libgcc] Error 1make[2]: Leaving directory `/opt/gcc-4.6-build'make[1]: *** [stage1-bubble] Error 2make[1]: Leaving directory `/opt/gcc-4.6-build'make: *** yes checking for sys/types.h...

yes checking if libtool supports shared libraries... yes checking for getopt.h...